Ecora Patch Manager FAQ

Question:  What does it mean the patch report displays a message that the checksum is invalid and the file version is equal to or less than what is expected?

Answer:  When this occurs, you have most likely installed a non-security patch that installs a file that is also included in one of the security hotfixes, however, the file in the non-security patch is a more recent version of the file. If this is the case, the computer may be protected from the vulnerability because later versions of the same file contain fixes that are released in earlier versions of the file.